Org-mode mailing list
 help / color / mirror / Atom feed
* [PATCH] org-protocol: Make org protocol defaults work on windows
@ 2020-11-20 16:26 Robert
  2020-11-25  6:18 ` Kyle Meyer
  2021-03-28 17:02 ` Maxim Nikulin
  0 siblings, 2 replies; 3+ messages in thread
From: Robert @ 2020-11-20 16:26 UTC (permalink / raw)
  To: emacs-orgmode; +Cc: Robert

[-- Attachment #1: Type: text/plain, Size: 161 bytes --]

Hei,

Attached a little patch to make the default org-protocol handlers work on windows.

Tested with Windows 10 and emacs 27.1

Best Regards

Robert


[-- Attachment #2: 0001-org-protocol-Make-org-protocol-defaults-work-on-wind.patch --]
[-- Type: application/octet-stream, Size: 1903 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] org-protocol: Make org protocol defaults work on windows
  2020-11-20 16:26 [PATCH] org-protocol: Make org protocol defaults work on windows Robert
@ 2020-11-25  6:18 ` Kyle Meyer
  2021-03-28 17:02 ` Maxim Nikulin
  1 sibling, 0 replies; 3+ messages in thread
From: Kyle Meyer @ 2020-11-25  6:18 UTC (permalink / raw)
  To: Robert; +Cc: emacs-orgmode

Robert writes:

> Hei,
>
> Attached a little patch to make the default org-protocol handlers work on windows.
>
> Tested with Windows 10 and emacs 27.1

Thank you for the patch.

Any org-protocol and/or Windows users out there that can provide
feedback?


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] org-protocol: Make org protocol defaults work on windows
  2020-11-20 16:26 [PATCH] org-protocol: Make org protocol defaults work on windows Robert
  2020-11-25  6:18 ` Kyle Meyer
@ 2021-03-28 17:02 ` Maxim Nikulin
  1 sibling, 0 replies; 3+ messages in thread
From: Maxim Nikulin @ 2021-03-28 17:02 UTC (permalink / raw)
  To: emacs-orgmode

On 20/11/2020 23:26, Robert wrote:
> Attached a little patch to make the default org-protocol
> handlers work on windows.

Unsure, but the issue might be addressed by the following change:
https://code.orgmode.org/bzg/org-mode/commit/928e67df
org-protocol: Allow slashes after sub-protocol

I am curious if alternative approach could help. Have you tried
one or three slashes after "org-protocol:"? E.g.
org-protocol:/capture?template=... or
org-protocol:///capture?template=... instead of
org-protocol://capture?template=...

I suspect that with double slash subprotocol is considered as a name
of some host so "/" as path before query part is added. With other
number of slashes subprotocol does not look like a host name
similar to file:/// scheme. See
https://orgmode.org/list/s3flvl$a48$1@ciao.gmane.io/



^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-03-28 17:03 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-20 16:26 [PATCH] org-protocol: Make org protocol defaults work on windows Robert
2020-11-25  6:18 ` Kyle Meyer
2021-03-28 17:02 ` Maxim Nikulin

Org-mode mailing list

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://orgmode.org/list/0 list/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 list list/ https://orgmode.org/list \
		emacs-orgmode@gnu.org
	public-inbox-index list

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.emacs.orgmode
	nntp://news.gmane.io/gmane.emacs.orgmode


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git