Org-mode mailing list
 help / color / mirror / Atom feed
* New bidi problems with org-mode (Arabic, Hebrew,..)
@ 2020-11-03 16:31 Fr Ml
  2020-11-06 17:22 ` Samim Pezeshki
  0 siblings, 1 reply; 3+ messages in thread
From: Fr Ml @ 2020-11-03 16:31 UTC (permalink / raw)
  To: emacs-orgmode

[-- Attachment #1: Type: text/html, Size: 2507 bytes --]

[-- Attachment #2: bidi_org_problem2.png --]
[-- Type: image/png, Size: 48361 bytes --]

[-- Attachment #3: bidi_org_problem1.png --]
[-- Type: image/png, Size: 59462 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: New bidi problems with org-mode (Arabic, Hebrew,..)
  2020-11-03 16:31 New bidi problems with org-mode (Arabic, Hebrew,..) Fr Ml
@ 2020-11-06 17:22 ` Samim Pezeshki
       [not found]   ` <00134ef6-a66a-ea1b-1531-f010c147cee9@t-online.de>
  0 siblings, 1 reply; 3+ messages in thread
From: Samim Pezeshki @ 2020-11-06 17:22 UTC (permalink / raw)
  To: emacs-orgmode, Fr Ml

[-- Attachment #1: Type: text/plain, Size: 2055 bytes --]

Hi,

I have no problem. I could not reproduce the issue. I tried Persian
language only.
Can the problem be of your theme? Have you tried other themes?
Please also try reproducing this with emacs -q (load Emacs with no
configuration).
Does this happen when the line exceeds a certain number of characters?
Does this happen on all org heading levels?

Regards,
Samim

Excerpts from Fr Ml's message of November 3, 2020 8:01 pm:
> https://emacs.stackexchange.com/questions/61494/
> new-bidi-problems-with-org-mode-arabic-hebrew
>
> Hallo,
>
> Some time ago (maybe 3 months) I've noticed some problems with the bidi support
> (right-to-left languages) in org-mode.
>
> One problem I can't reproduce: The characters have then a strange form but If I
> change the text scale (larger or smaller) it becomes normal.
>
> The second problem I can reproduce, you can see it in the two images:
>
> In this image: I have the option `bidi-paragraph-direction: nil`, to get the
> right direction for  Hebrew and Arabic. As you see the headline color isn't
> consistently brown. The English text don't have this problem.
>
> [![The color of the headline changes, gets black. The direction is right to
> left][1]][1]
>
> In this image without the option: Everything is ok:
> [![Here it's ok, the direction is left to right][2]][2]
>
> In both examples my init file is empty. And I've tried many fonts. My org
> version is 9.3 and emacs version is 27.1.
>
> Actually, the first problem is bigger for me but I can't reproduce it; I think
> that both problems appeared a the same time. So maybe solving the second will
> solve the first one too(?)
>
> EDIT: I can reproduce the problem with the colors also on a Windows machine
> with latest version: emacs 27.1 and the included org 9.3. With the older
> version: emacs 26.3 and the included org-version 9.1.7 I don't have the problem
> - at least I didn't see it.
>
>   [1]: https://i.stack.imgur.com/NVUMY.png
>   [2]: https://i.stack.imgur.com/emHDx.png
>
>
>
>
>

[-- Attachment #2: Type: application/pgp-signature, Size: 488 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: New bidi problems with org-mode (Arabic, Hebrew,..)
       [not found]   ` <00134ef6-a66a-ea1b-1531-f010c147cee9@t-online.de>
@ 2020-11-07 20:34     ` Samim Pezeshki
  0 siblings, 0 replies; 3+ messages in thread
From: Samim Pezeshki @ 2020-11-07 20:34 UTC (permalink / raw)
  To: Fr Ml, emacs-orgmode

[-- Attachment #1: Type: text/plain, Size: 3351 bytes --]

The attached screenshot is how I see the file you sent on my screen
using emacs -q
I see no problem in it. Please correct me if I am wrong.

Emacs 27.1
Archlinux

Regards,
Samim

Excerpts from Fr Ml's message of November 7, 2020 10:03 pm:
> Hi Samim,
>
> thanks for your answer.
>
> I tested it again with the -q option: Still have the problem (of course if I
> have in the first line: -*- bidi-paragraph-direction: nil; truncate-lines: nil;
> -*-)
>
> - It happens only at line breaks. I think always if a word is divided. But also
> in some other cases (the new line doesn't start with space). I don't think it
> depends of the length: If I enlarge the text size it changes.
>
> - Yes, it happens on all levels. And it happens also bei the underscore '_'
> (part3).
>
> As I noticed in the additional edit: It happens also on windows.
>
> Regards,
> Frank
>
> P.S. I've attached the org file too with some pictures of it.
>
>
> On 11/6/20 6:22 PM, Samim Pezeshki wrote:
>
>     Hi,
>
>     I have no problem. I could not reproduce the issue. I tried Persian
>     language only.
>     Can the problem be of your theme? Have you tried other themes?
>     Please also try reproducing this with emacs -q (load Emacs with no
>     configuration).
>     Does this happen when the line exceeds a certain number of characters?
>     Does this happen on all org heading levels?
>
>     Regards,
>     Samim
>
>     Excerpts from Fr Ml's message of November 3, 2020 8:01 pm:
>
>         https://emacs.stackexchange.com/questions/61494/
>         new-bidi-problems-with-org-mode-arabic-hebrew
>
>         Hallo,
>
>         Some time ago (maybe 3 months) I've noticed some problems with the bidi support
>         (right-to-left languages) in org-mode.
>
>         One problem I can't reproduce: The characters have then a strange form but If I
>         change the text scale (larger or smaller) it becomes normal.
>
>         The second problem I can reproduce, you can see it in the two images:
>
>         In this image: I have the option `bidi-paragraph-direction: nil`, to get the
>         right direction for  Hebrew and Arabic. As you see the headline color isn't
>         consistently brown. The English text don't have this problem.
>
>         [![The color of the headline changes, gets black. The direction is right to
>         left][1]][1]
>
>         In this image without the option: Everything is ok:
>         [![Here it's ok, the direction is left to right][2]][2]
>
>         In both examples my init file is empty. And I've tried many fonts. My org
>         version is 9.3 and emacs version is 27.1.
>
>         Actually, the first problem is bigger for me but I can't reproduce it; I think
>         that both problems appeared a the same time. So maybe solving the second will
>         solve the first one too(?)
>
>         EDIT: I can reproduce the problem with the colors also on a Windows machine
>         with latest version: emacs 27.1 and the included org 9.3. With the older
>         version: emacs 26.3 and the included org-version 9.1.7 I don't have the problem
>         - at least I didn't see it.
>
>           [1]: https://i.stack.imgur.com/NVUMY.png
>           [2]: https://i.stack.imgur.com/emHDx.png
>
>
>
>
>
>
>

[-- Attachment #2: bla.org --]
[-- Type: text/plain, Size: 1542 bytes --]

-*- bidi-paragraph-direction: nil; truncate-lines: nil; -*-

* سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام 
** שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום 
*** سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام 
**** שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום 
***** سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام 
****** שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום 


_سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام سلام_
_שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום שלום_ 


[-- Attachment #3: blah.png --]
[-- Type: image/png, Size: 42919 bytes --]

[-- Attachment #4: Type: application/pgp-signature, Size: 488 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2020-11-07 20:35 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-03 16:31 New bidi problems with org-mode (Arabic, Hebrew,..) Fr Ml
2020-11-06 17:22 ` Samim Pezeshki
     [not found]   ` <00134ef6-a66a-ea1b-1531-f010c147cee9@t-online.de>
2020-11-07 20:34     ` Samim Pezeshki

Org-mode mailing list

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://orgmode.org/list/0 list/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 list list/ https://orgmode.org/list \
		emacs-orgmode@gnu.org
	public-inbox-index list

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.emacs.orgmode
	nntp://news.gmane.io/gmane.emacs.orgmode


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git